Users may have trouble accessing Commerce Max and/or Commerce Yield UI

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 22:36 CET

Investigating

Users may have trouble accessing the Commerce Max and/or Commerce Yield UI.

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Mar 09, 2026 - 22:22 CET
This incident affected: Commerce Max & Yield - UI (Campaigns, Analytics, Audiences, Catalog, Billing, Account Settings, Creatives).