Users may have trouble with Management Center component performance.
Incident Report for Criteo Services
Resolved
Users may have trouble using Management Center component.

Thank you for bearing with us. We have confirmed that the issue is now fixed and we are monitoring results. We apologize for any disruption caused.
Posted May 17, 2022 - 15:21 CEST
Identified
Users may have trouble using Management Center component.

The team has identified the root cause behind this incident and we are working to push an update to correct the issue. We apologize for any disruption caused.
Posted May 13, 2022 - 17:05 CEST
This incident affected: Marketing Solutions: Commerce Growth (Analytics) and Marketing Solutions: API (Analytics).