Users may have trouble with Commerce Growth component performance

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 14:16 CET

Investigating

Some users may have trouble editing their adsets in Commerce Growth.

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Mar 17, 2026 - 09:15 CET
This incident affected: Commerce Growth - UI (Campaigns).