Users may have trouble with Commerce Max and/or Commerce Yield Campaigns Component

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:55 CEST

Investigating

Users may have trouble using Commerce Max and/or Commerce Yield Campaigns Component

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Mar 31, 2026 - 12:43 CEST
This incident affected: Commerce Max & Yield - UI (Campaigns) and Commerce Max & Yield - API (Campaign).