Data Processing Delays - Commerce Max and Yield API Tools Affected

Incident Report for Criteo Services

Resolved

Our data processing infrastructure was running behind which is causing inaccuracies in the reporting API for Commerce Max and Commerce Yield.

The issue was resolved and the data is catching up to expected values.
Posted Sep 18, 2025 - 22:59 CEST

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting API for Commerce Max and Commerce Yield.

No data has been lost and the incident is being investigated.
Posted Sep 18, 2025 - 12:22 CEST
This incident affected: Commerce Max & Yield - API (Analytics).