Data Processing Delays - Reporting Tools Affected

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 10:51 CEST

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools.

No data has been lost and the incident is being investigated.
Posted Jun 06, 2025 - 12:50 CEST
This incident affected: Commerce Growth - API (Analytics), Commerce Growth (Analytics), Commerce Max & Yield (Analytics), and Commerce Max & Yield - API (Analytics).