Users may have trouble with Commerce Growth component performance

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 18:15 CET

Investigating

Users may have trouble using updating impression tracking within the Commerce Growth UI
Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Mar 05, 2026 - 15:54 CET
This incident affected: Commerce Growth - UI (Campaigns, Analytics, Audiences, Product Catalog, Creative library, OneTag - Event Tracking, Biling and payments, Account Settings, Performance planner, Experiments).