Users may have trouble accessing Commerce Max Line Items Dashboard and Analytics

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 12:58 CET

Investigating

Users may have trouble accessing Commerce Max Line Items Dashboard and Analytics

Our team is investigating and we will communicate more information as soon as we have it. We apologize for any disruption caused.
Posted Feb 28, 2025 - 11:42 CET
This incident affected: Commerce Max & Yield (Campaign, Analytics).