Users in Australia may have trouble with Commerce Max and/or Commerce Yield component performance

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 06:51 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 17, 2026 - 06:50 CEST

Investigating

Users in Australia may have trouble using Commerce Max and/or Commerce Yield component

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Jul 17, 2026 - 06:19 CEST
This incident affected: Commerce Max & Yield - UI (Campaigns, Analytics, Audiences, Billing, Account Settings, Creatives).