Users may have trouble with Criteo API analytics performance

Incident Report for Criteo Services

Resolved

This incident has been resolved. There should be no more delays with the RM API.
Posted Sep 15, 2025 - 15:55 CEST

Monitoring

The incident has improved and report generation is currently working. We are continuing to monitor the situation for any possible recurrence of the issue
Posted Sep 12, 2025 - 21:13 CEST

Update

Users of the Retail Media API may experience extended times when generating reports during peak user activity.

We have identified the root cause behind this incident and are working on restoring a full service.
Posted Sep 12, 2025 - 19:06 CEST

Identified

Users of the Retail Media API may experience extended times when generating reports during peak user activity.

We have identified the root cause behind this incident and are working on restoring a full service.
Posted Sep 12, 2025 - 19:04 CEST

Investigating

Users may have trouble using Criteo API Analytics.

Our team is investigating and we will communicate more information as soon as we have it. We apologize for any disruption caused.
Posted Sep 11, 2025 - 15:55 CEST
This incident affected: Commerce Max & Yield - API (Campaign, Analytics, Audiences, Catalog, Account Management, Gateway, Billing, Balances, oAuth, Recommendation).