Users may have trouble with slow loading of the Commerce Growth website

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Feb 21, 2025 - 13:16 CET

Identified

Users may have trouble with slow loading of the Commerce Growth website

We have identified the root cause behind this incident and are working on restoring a full service.
Posted Feb 21, 2025 - 12:02 CET
This incident affected: Commerce Growth (Campaign, Analytics, Audiences, Catalog, Account Management).