Users may have trouble with Commerce Max component performance.
Incident Report for Criteo Services
Resolved
We are pleased to announce that our user interface and API have remained stable following the analysis and reporting platform issues we previously communicated.

Data delays have been resolved and reports should be up to date. Campaign creation and ad delivery are working normally, and billing has remained unaffected.

We will continue to monitor our systems before implementing additional mitigation measures.

If you experience any difficulties using the analytics and reporting platform, please contact your AS.
We thank you for your patience.
Posted Oct 26, 2023 - 18:09 CEST
Update
The improvement in the platform experience since October 19th continued over the weekend, but we will keep monitoring very carefully for an extended period before relaxing mitigation measures.

Campaign creation and ad delivery are working as normal. Billing is not affected. Reporting is more stable during off-peak hours, typically after 3pm ET. We are actively working at high priority to improve your experience.

We apologize for any inconvenience and thank you for your patience.
Posted Oct 24, 2023 - 10:34 CEST
Monitoring
Over the past 48 hours, we have taken a number of steps to restore the platform to normal operation, and since October 19, we have seen an improvement in the platform experience. However, we remain cautious and need to see an improvement in system performance over an extended period before relaxing mitigation measures.

Campaign creation and ad delivery are working as normal. Billing is not affected. Reporting is more stable during off-peak hours, typically after 3pm ET.

We are actively working at high priority to improve your experience. We apologize for any inconvenience and thank you for your patience. We'll share another update on Monday morning, October 23 (ET).
Posted Oct 20, 2023 - 12:41 CEST
Update
RMP Campaign, Line item, and Analytics pages may be slow to load due to ongoing technical issues.

Campaign creation and ad delivery are working as normal. Billing is not affected.

Reporting is more stable during off-peak hours, typically after 3pm ET.

We are actively working at high priority to improve your experience. We apologize for any inconvenience and thank you for your patience. We'll share another update on Friday morning, October 20 (ET).
Posted Oct 19, 2023 - 17:55 CEST
Investigating
Users may have trouble using Commerce Max component.

Our team is investigating and we'll follow up with more information as soon as we have it. We apologize for any disruption caused.
Posted Oct 16, 2023 - 17:49 CEST
This incident affected: Commerce Max & Yield (Campaign, Analytics, Audiences) and Commerce Max & Yield - API (Campaign, Analytics, Audiences).