Users may have trouble accessing Commerce Max and/or Commerce Yield UI and API components

Incident Report for Criteo Services

Resolved

Incident has been resolved
Posted Apr 25, 2026 - 16:51 CEST

Monitoring

The issue has been identify and fixed. Criteo's tech team are monitoring.
Posted Apr 25, 2026 - 16:41 CEST

Update

We are continuing to investigate this issue.
Posted Apr 25, 2026 - 16:22 CEST

Investigating

Users may have trouble accessing Commerce Max and/or Commerce Yield component.

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Apr 25, 2026 - 16:21 CEST
This incident affected: Commerce Max & Yield - UI (Campaigns, Analytics, Audiences, Catalog, Billing, Account Settings, Creatives) and Commerce Max & Yield - API (Campaign, Analytics, Audiences, Catalog, Account Management, Gateway, Billing, Balances, oAuth, Recommendation).