Users may have trouble accessing the Creative library

Incident Report for Criteo Services

Resolved

Users can access the Creative Library again
Posted Aug 15, 2025 - 23:41 CEST

Investigating

Users may have trouble accessing the Creative library

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Aug 15, 2025 - 13:36 CEST
This incident affected: Commerce Max & Yield - UI (Campaigns).