Users may have trouble with Commerce Max and/or Commerce Yield component performance

Incident Report for Criteo Services

Resolved

Users may have trouble using Commerce Max and/or Commerce Yield component.

We have confirmed that the incident is over and that the service is operating normally.
Posted Sep 09, 2025 - 14:31 CEST

Investigating

Users may have trouble using Commerce Max and/or Commerce Yield component

Our team is investigating and we will communicate more information as soon as we have it.

We apologize for any disruption caused.
Posted Sep 09, 2025 - 14:16 CEST
This incident affected: Commerce Max & Yield - UI (Campaigns, Analytics, Audiences, Catalog, Billing, Account Settings, Creatives).