Users may have trouble accessing Criteo UI and APIs.

Incident Report for Criteo Services

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 17:15 CEST

Identified

Users may have trouble accessing Criteo UI and APIs.

We are currently experiencing a global service outage affecting our platforms and public apis. We have identified the likely root cause, and our engineering teams are actively working on implementing a fix. We will continue to provide updates as we make progress. Thank you for your patience.
Posted Jul 29, 2026 - 16:50 CEST
This incident affected: Commerce Max & Yield - UI (Campaigns, Analytics, Audiences, Billing, Account Settings, Creatives) and Commerce Max & Yield - API (Campaign, Analytics, Audiences, Catalog, Account Management, Gateway, Partner Billing Report, Balances, oAuth, Recommendation).