Users may have trouble with Commerce Growth component performance
Incident Report for Criteo Services
Resolved
This incident has been resolved.
Posted Nov 01, 2024 - 19:59 CET
Investigating
Users may have trouble using Commerce Growth component.

Our team is investigating and we will communicate more information as soon as we have it. We apologize for any disruption caused.
Posted Nov 01, 2024 - 17:20 CET
This incident affected: Commerce Growth (Campaign, Analytics, Audiences, Catalog, Account Management).