Update - We’ve identified the root cause of the issue affecting offsite campaign reporting for markets operating in currencies other than EUR. Our teams are currently building a fix, with the release planned for November 12th, 2025.
Please note: This is a UI display issue only — campaign performance, data collection, and delivery remain unaffected.
We appreciate your continued patience and understanding while we work to fully resolve this issue.
Posted Nov 06, 2025 - 15:24 CET
Investigating
We’ve identified an issue affecting offsite campaign reporting for markets operating in currencies other than EUR. Sales data in the UI currently display values converted to EUR but with the local currency sign (e.g., 30 JPY instead of 5,200 JPY).
Impact: - KPIs impacted: Sales, ROAS, Units - Scope: All offsite retailers not using EUR - Root cause: Under investigation
Please note: This is a UI display issue only — campaign performance, data collection, and delivery remain unaffected.
We’re actively working on a fix and will update this incident once the issue is resolved.
Posted Nov 05, 2025 - 18:22 CET
This incident affects: Commerce Max & Yield - UI (Campaigns, Analytics).