Users may have trouble with Commerce Max's line item reporting dashboard

Incident Report for Criteo Services

Resolved

All our data and reporting are now up to date and operating normally.
Posted Jul 08, 2024 - 03:04 CEST

Identified

Users may have trouble using Commerce Max's line item reporting dashboard.

We have identified the root cause behind this incident and full service is being restored.
Posted Jul 05, 2024 - 21:19 CEST
This incident affected: Commerce Max & Yield (Analytics).